BUSCARV con múltiples criterios - Tutoriales de Excel TOP

La mayoría de los usuarios de Excel piensan que BUSCARV sólo se puede utilizar con un único criterio; Hasta hace unos meses creía que esto también era así. En el pasado había usado ÍNDICE/COINCIDIR o columnas auxiliares porque no había apreciado cuánto se podía lograr con la combinación BUSCARV ELEGIR. Ya nos hemos fijado en esta combinación al descubrir cómo BUSCAR V a la izquierda . Pero, como verás, podemos llevar esta combinación aún más lejos.

Índice
  1. BUSCARV ELEGIR Combinación
  2. ¿Cómo funciona la combinación BUSCARV ELEGIR (Matriz)?
  3. Comentarios de notas
  4. Resumen
  5. Descargue la hoja de referencia de BUSCARV avanzada
  6. Otras publicaciones en la serie Mastering VLOOKUP

BUSCARV ELEGIR Combinación

Comencemos con un ejemplo básico. Trabaja para una empresa con la siguiente lista de teléfonos:

BUSCARV múltiples criterios

¡Guau! Hay muchas personas con el nombre Paul y muchas personas con el apellido Daniels. Eso es curioso, ¿cuáles son las posibilidades? Luego, su gerente le pedirá que cree una hoja de cálculo en la que deberá buscar el número de teléfono de determinadas personas. De repente, la repetición de los nombres ya no tiene gracia, ahora resulta muy dolorosa. ¿Cómo podrás separar a todos los de Pablo y a todos los de Daniel?

BUSCARV al rescate!!!

Todavía podemos usar una fórmula BUSCARV en este escenario para devolver el valor. ¡En serio podemos!

BUSCARV ELEGIR múltiples criterios

La fórmula en la celda F6 devuelve una búsqueda tanto en la Columna A como en la Columna B para encontrar el número de teléfono de Paul McCartney. La fórmula en esta celda es:

{=BUSCARV(F3"^"F4,ELEGIR({1,2},A2:A8"^"B2:B8,C2:C8),2,FALSO)}

Usando esta fórmula, es posible buscar el Nombre y Apellido para devolver el Número de Teléfono. Esta es una fórmula de matriz, lo que significa que la fórmula se ingresa sin { } al principio y al final de la fórmula (todavía ingresamos { } en el medio). Al presionar Ctrl+Shift+Enter se ingresará la fórmula y Excel agregará automáticamente { } al inicio y al final de la fórmula.

¿Cómo funciona la combinación BUSCARV ELEGIR (Matriz)?

Dividamos esta fórmula en partes separadas.

{=BUSCARV(F3"^"F4,ELEGIR({1,2},A2:A8"^"B2:B8,C2:C8),2,FALSO)}

Las secciones resaltadas arriba son la fórmula BUSCARV estándar que conocemos. La única diferencia es que las celdas F3 y F4 se combinan con un carácter espaciador. El resultado de F3”^”F4 es “Paul^McCartney”

{=BUSCARV(F3"^"F4,ELEGIR({1,2},A2:A8"^"B2:B8,C2:C8),2,FALSO)}

La sección resaltada arriba indica que la columna 1 para BUSCARV debe ser la combinación de la columna A y la columna B separadas por un carácter espaciador. Como se trata de una fórmula de matriz, esta sección crea un rango temporal de valores que sería el siguiente.

Fila 2= “Paul^Daniels”
Fila 3= “Jack^Daniels”
Fila 4= “Paul^Newman”
Fila 5= “Paul^McCartney”
Fila 6= “Jeff^Daniels”
Fila 7= “Paul^Simon”
Fila 8 = “Antonio^Daniels”

Suponiendo que se encuentre una coincidencia (fila 5 en nuestro ejemplo), devolverá el valor de la columna 2.

{=BUSCARV(F3"^"F4,ELEGIR({1,2},A2:A8"^"B2:B8,C2:C8),2,FALSO)}

En nuestra fórmula ELEGIR, la columna 2 se define como las celdas C2-C8. Por lo tanto, el número de teléfono de Paul McCartney se devuelve como 555-9867.

Comentarios de notas

Aquí hay algunas cosas que debe tener en cuenta:

  • Es posible utilizar esta fórmula con otras técnicas presentadas en esta serie Mastering BUSCARV (como el método BUSCARV doble para cálculos más rápidos)
  • Si vuelve a hacer clic en la fórmula y no la ingresa con Ctrl+Shift+Enter, se mostrará un error. Debes Ctrl+Shift+Enter cada vez.
  • De todos los métodos de búsqueda de múltiples criterios, este es uno de los más bajos de calcular.

Para otros ejemplos de la combinación BUSCARV ELEGIR lea “ Cómo BUSCARV a la izquierda ”

Resumen

Una vez más, BUSCARV demuestra ser más diversa de lo que parece a primera vista. Al dominar esta técnica, podrás hacer cosas con BUSCARV con las que la mayoría de los usuarios de Excel sólo pueden soñar.

Descargue la hoja de referencia de BUSCARV avanzada

Descargue la hoja de referencia de BUSCARV avanzada. Incluye la mayoría de los consejos y trucos que hemos cubierto en esta serie, incluidos cálculos más rápidos, criterios múltiples, búsqueda por la izquierda y mucho más.

Descárgalo y fíjalo en el trabajo; incluso puedes reenviarlo a tus amigos y compañeros de trabajo.

Hoja de referencia avanzada de BUSCARV

Descargue el archivo de ejemplo: únase al programa Insiders gratuito y obtenga acceso al archivo de ejemplo utilizado para esta publicación.

Nombre del archivo: 0166 BUSCARV Avanzada.pdf

Tener acceso

Otras publicaciones en la serie Mastering VLOOKUP

  • Cómo utilizar BUSCARV
  • BUSCARV: ¿Qué hace la declaración Verdadero/Falso?
  • BUSCARV: Cómo calcular más rápido
  • Cómo BUSCAR V a la izquierda
  • BUSCARV: cambia el número de columna automáticamente
  • BUSCARV con múltiples criterios
  • Usando comodines con BUSCARV
  • Cómo usar BUSCARV con columnas y filas
  • Expandir automáticamente el rango de datos BUSCARV
  • BUSCARV: busque el enésimo elemento (sin columnas auxiliares)
  • BUSCARV: enumera todos los elementos coincidentes
  • Hoja de referencia avanzada de BUSCARV

Este sitio utiliza cookies para una mejor experiencia - Mas información